Release 3.6.5 | January 15, 2019

Required Android 4.4 (KitKat) or later. Compatible with phones and tablets on Android.

Corrections and changes:

  • Internal improvements and optimization.
Have more questions? Submit a request

0 Comments

Article is closed for comments.